Topologi jaringan adalah bagian yang menjelaskan hubungan antar komputer yang di bangun berdasarkan kegunaan, keterbatasan resource dan keterbatasan biaya, berarti topologi-topologi jaringan yang ada bisa disesuaikan dengan keadaan di lapangan. Jenis-jenis topologi jaringan adalah ...
This is featured post 2 title
Replace these every slider sentences with your featured post descriptions.Go to Blogger edit html and find these sentences.Now replace these with your own descriptions.This theme is Bloggerized by Lasantha - Premiumbloggertemplates.com.
This is featured post 3 title
Replace these every slider sentences with your featured post descriptions.Go to Blogger edit html and find these sentences.Now replace these with your own descriptions.This theme is Bloggerized by Lasantha - Premiumbloggertemplates.com.
This is featured post 4 title
Replace these every slider sentences with your featured post descriptions.Go to Blogger edit html and find these sentences.Now replace these with your own descriptions.This theme is Bloggerized by Lasantha - Premiumbloggertemplates.com.
This is featured post 5 title
Replace these every slider sentences with your featured post descriptions.Go to Blogger edit html and find these sentences.Now replace these with your own descriptions.This theme is Bloggerized by Lasantha - Premiumbloggertemplates.com.
SUSE Linux 9.0 ternyata sudah mempunyai paket RADIUS server yang terdiri dari:
1. Big Sister
Paket ini merupakan Big Sister plug-in untuk pemonitoran sebuah RADIUS server.
2. FreeRADIUS
Paket ini merupakan RADIUS server.
3. freeradius-devel
Paket ini berisi file-file untuk pengembangan FreeRADIUS
4. pam_radius
Pam_radius adalah suatu modul PAM yang digunakan untuk autentikasi pengguna pada RADIUS server.
5. radiusclient
RADIUS client memberikan beberapa program untuk proses autentikasi
melalui RADIUS server.
6. radiusd-livingston
Radiusd-livingston adalah RADIUS server dari Lucent Technologies
FreeRADIUS merupakan salah satu paket program yang terdapat di SUSE Linux 9.0, maka proses instalasinya relatif lebih mudah. Karena paket freeRADIUS bukan termasuk paket default yang otomatis terinstal apabila kita menginstal SUSE Linux 9.0, maka instalasinya harus dilakukan secara manual. Langkahlangkah proses instalasi paket freeRADIUS yang terdapat pada SUSE Linux 9.0
adalah sebagai berikut:
1. Kita dapat menggunakan program YaST. Ada dua cara untuk menjalankan
program YaST, cara pertama : Start Menu → System → YaST, apabila
kita login sebagai pengguna biasa (bukan super user),maka akan muncul
window yang meminta password root. Sedangkan cara yang kedua adalah
melalui konsole dan harus login sebagai root, kemudian ketik yast. Apabila
window YaSTControlCentersudah muncul, pada menu sebelah kiri pilih
Software, kemudian pilih Install and Remove Software. Agar tidak terlalu
binggung, kita dapat menggunakan fasilitas search untuk mencari paket
RADIUS, pada menu filter pilih search, ketik radius pada kolom isian,
tekan enter, maka akan muncul paket-paket RADIUS seperti yang telah
disebutkan diatas.
2. Pilih paket yang ingin kita instal.
3. Tekan tombol accept apabila sudah selesai memilih paket yang akan
diinstal.
Untuk lebih memperjelas proses instalasi freeRADIUS di SUSE Linux 9.0 diatas,
lihat Gambar 4 dibawah ini.
Gambar 4 YaST
Apabila kita telah memilih freeRADIUS sebagai RADIUS server, maka kita tidak
boleh memilih radiusd-livingston sebagai RADIUS server dan begitu juga
sebaliknya. Apabila kita memilih freeRADIUS dan radiusd-livingston bersamasama,
maka pada saat kita menekan tombol accept akan keluar window yang
berisi peringatan bahwa ada konflik. Untuk menghindari konflik tersebut, maka
kita harus memilih salah satu dari freeRADIUS dan radiusd-livingston yang akan
digunakan sebagai RADIUS server.
Dibawah ini merupakan cuplikan dari file /etc/raddb/users, file ini perlu diubah
dengan cara menghilangkan tanda “#“ pada baris-baris yang berisi konfigurasi.
# This is a complete entry for "steve". Note that there is no Fall-Through
# entry so that no DEFAULT entry will be used.
#
steve Auth-Type = Local, Password = "testing"
Service-Type = Framed-User,
Framed-Protocol = PPP,
Framed-IP-Address = 172.16.3.33,
Framed-IP-Netmask = 255.255.255.255,
Framed-Routing = Broadcast-Listen,
Framed-Filter-Id = "std.ppp",
Framed-MTU = 1500,
Framed-Compression = Van-Jacobson-TCP-IP
Untuk menjalankan freeRADIUS dari konsole gunakan perintah: radiusd , dan
untuk memastikan bahwa radiusd sudah berjalan, ketik ps –ax. Apabila ada
radiusd dalam daftar proses yang sedang berjalan, maka RADIUS server sudah
dapat digunakan.
Uji coba untuk mengetahui apakah RADIUS server yang kita instal tadi sudah
berjalan dengan baik atau tidak, dapat dilakukan dengan menggunakan perintah
radtest. Aturan pemakaian radtest harus menurut skript dibawah ini:
radtest user passwd radius-server[:port] nas-port-number secret [ppphint] [nasname]
Dari file /etc/raddb/users diatas, kita dapat menggunakan user “steve” dan
RADIUS (Remote Authentication Dial-In User Service), adalah suatu metode standar (protokol) yang mengatur komunikasi antara NAS dengan AAA server. Dalam hal ini server AAA yang digunakan dapat juga disebut sebagai server RADIUS, dan paket-paket data yang terlibat dalam komunikasi antara keduanya disebut sebagai paket RADIUS.
Ketika NAS menerima permintaan koneksi dari user, NAS akan mengirimkan informasi yang diperolehnya dari user ke server RADIUS. Berdasarkan informasi tersebut, server RADIUS akan mencari dan mencocokkan informasi mengenai user tersebut pada databasenya, baik internal, eksternal, maupun server RADIUS lain. Jika terdapat informasi yang cocok, server RADIUS akan mengizinkan user tersebut untuk menggunakan jaringan. Jika tidak, maka user tersebut akan ditolak. Berdasarkan informasi ini, NAS memutuskan apakah melanjutkan atau memutuskan koneksi dengan user. Selanjutnya, NAS mengirimkan data ke server RADIUS untuk mencatat semua kegiatan yang dilakukan user dalam jaringan.
Server RADIUS dan NAS berkomunikasi melalui paket-paket RADIUS. Paket-paket RADIUS ini memiliki format sesuai dengan yang ditentukan oleh IETF melalui dokumen RFC 2865 mengenai RADIUS, dan RFC 2866 mengenai RADIUS accounting. Paket-paket RADIUS dikirimkan oleh NAS dan server RADIUS berdasarkan pola request/response : NAS mengirimkan request dan menerima response dari server RADIUS. Jika NAS tidak menerima response dari server atas suatu request, NAS dapat mengirimkan kembali paket request secara periodik sampai dicapai suatu masa timeout tertentu, dimana NAS tidak lagi mengirimkan request kepada server, dan menyatakan bahwa server sedang down/tidak aktif. Setiap paket memiliki fungsi tersendiri, apakah untuk authentication atau untuk accounting. Setiap paket RADIUS dapat menyertakan nilai-nilai tertentu yang disebut atribut (attributes). Atribut-atribut ini bergantung pada jenis paket (authentication atau accounting), dan jenis NAS yang digunakan. Informasi detail mengenai format paket dan nilai-nilai dari masing-masing field dalam paket RADIUS dapat dilihat pada RFC 2865 dan RFC 2866.
Fungsi authentication dilakukan melalui field-field pada paket access-request. Fungsi authorization dilakukan melalui atribut-atribut pada paket access-accept. Fungsi accounting dilakukan melalui atribut-atribut pada paket-paket accounting (paket start, stop, on, off, dll).
Keamanan pada komunikasi antara NAS dengan server RADIUS dijamin dengan digunakannya konsep shared secret. Shared secret merupakan rangkaian karakter alfanumerik unik yang hanya diketahui oleh server RADIUS dan NAS, dan tidak pernah dikirimkan ke jaringan. Shared secret ini digunakan untuk mengenkripsi informasi-informasi kritis seperti user password. Enkripsi dilakukan dengan cara melewatkan shared secret yang diikuti dengan request authenticator (field pada paket access request dari NAS yang menandakan bahwa paket tersebut merupakan paket access request) pada algoritma MD5 satu arah, untuk membuat rangkaian karakter sepanjang 16 oktet, yang kemudian di-XOR-kan dengan password yang dimasukkan oleh user. Hasil dari operasi ini ditempatkan pada atribut User-Password pada paket access request. Karena shared secret ini hanya diketahui oleh NAS dan server RADIUS, dan tidak pernah dikirimkan ke jaringan, maka akan sangat sulit untuk mengambil informasi user-password dari paket access request tersebut.
NAS dan server RADIUS terhubung melalui jaringan TCP/IP. Protokol yang digunakan adalah UDP (User Datagram Protocol), dan menggunakan port 1812 untuk authentication, dan port 1813 untuk accounting.
Remote Authentication Dial-In User Service (sering disingkat menjadi RADIUS) adalah sebuah protokol keamanan komputer yang digunakan untuk melakukan autentikasi, otorisasi, dan pendaftaran akun pengguna secara terpusat untuk mengakses jaringan. RADIUS didefinisikan di dalam RFC 2865 dan RFC 2866, yang pada awalnya digunakan untuk melakukan autentikasi terhadap akses jaringan secara jarak jauh dengan menggunakan koneksi dial-up. RADIUS, kini telah diimplementasikan untuk melakukan autentikasi terhadap akses jaringan secara jarak jauh dengan menggunakan koneksi selain dial-up, seperti halnya Virtual Private Networking (VPN), access point nirkabel, switch Ethernet, dan perangkat lainnya.
Radius banyak dipakai oleh Provider dan ISP internet untuk authentikasi dan billingnya. Radius juga bisa dipakai oleh jaringan RT/RW-Net untuk authentikasi para penggunanya dan untuk mengamankan jaringan RT/RW-Net yang ada. Di indonesia sudah ada service radius, namun berbayar seperti indohotspot.net . Ada juga service yang tidak berbayar, dan dikelola oleh luar negeri seperti chillidog.org Selain lebih menghemat budget, dan juga menghemat biaya maintenance, sistem Radius yang di host di internet merupakan salah satu solusi murah untuk para penggagas sistem HotSpot.
Beberapa alasan pemilihan RADIUS server untuk sistem autentikasi adalah
sederhana, efisien, dan mudah diimplementasikan. RADIUS server akan
mempermudah tugas administrator untuk mengelola wireless LAN, karena sistem
ini merupakan suatu sistem administrasi yang terpusat. Fitur RADIUS server yang
lain adalah RADIUS server dapat digunakan untuk memfilter alamat MAC dari
wireless card yang dimiliki oleh pengguna, alamat MAC beserta identitas
pengguna dimasukkan ke dalam database yang terdapat di RADIUS server.
RADIUS menjalankan sistem administrasi pengguna yang terpusat, sistem ini
akan mempermudah tugas administrator. Dapat kita bayangkan berapa banyak
jumlah pelanggan yang dimiliki oleh sebuah ISP, dan ditambah lagi dengan
penambahan pelanggan baru dan penghapusan pelanggan yang sudah tidak
berlangganan lagi. Apabila tidak ada suatu sistem administrasi yang terpusat,
maka akan merepotkan administrator dan tidak menutup kemungkinan ISP akan
merugi atau pendapatannya berkurang. Dengan sistem ini pengguna dapat
menggunakan hotspot di tempat yang berbeda-beda dengan melakukan autentikasi
ke sebuah RADIUS server.
RADIUS merupakan suatu protokol yang dikembangkan untuk proses AAA
(authentication, authorization, and accounting.)
Berikut ini adalah RFC (Request For Comment) yang berhubungan dengan
RADIUS [2]:
• RFC2865 : Remote Authentication Dial-In User Service (RADIUS)
• RFC 2866 : RADIUS Accounting
• RFC 2867 : RADIUS Accounting for Tunneling
• RFC 2868 : RADIUS Authentication for Tunneling
• RFC2869 : RADIUS Extensions
• RFC 3162 : RADIUS over IP6
• RFC 2548 : Microsoft Vendor-Specific RADIUS Attributes
Pada awal pengembangannya, RADIUS menggunakan port 1645, yang ternyata
bentrok dengan layanan “datametrics”. Sekarang, port yang dipakai RADIUS
adalah port 1812 [3].
Struktur Paket Data RADIUS
Struktur paket data RADIUS pada Gambar 1 terdiri dari lima bagian, yaitu:
1. Code
Code memiliki panjang adalah satu oktet, digunakan untuk membedakan tipe
pesan RADIUS yang dikirimkan pada paket. Kode-kode tersebut (dalam
desimal) ialah:
1 Access-Request
2 Access-Accept
3 Access-Reject
4 Accounting-Request
5 Accounting-Response
11 Access-Challenge
12 Status-Server
13 Status-Client
255 Reserved
2. Identifier
Memiliki panjang satu oktet, bertujuan untuk mencocokkan permintaan.
3. Length
Memiliki panjang dua oktet, memberikan informasi mengenai panjang paket.
4. Authenticator
Memiliki panjang 16 oktet, digunakan untuk membuktikan balasan dari
RADIUS server, selain itu digunakan juga untuk algoritma password.
5. Attributes
Berisikan informasi yang dibawa pesan RADIUS, setiap pesan dapat
membawa satu atau lebih atribut. Contoh atribut RADIUS: nama pengguna,
password, CHAP-password, alamat IP access point(AP), pesan balasan.
Versi 10 Avira AntiVir kini siap diunduh. Selain merombak tampilan, perusahaan antivirus asal Jerman ini juga hadir dengan jurus keamanan terbaru.
Pada peluncurannya kali ini pengguna tak hanya bisa mencicipi antivirus gratis dengan Avira AntiVir Personal, namun juga Avira AntiVir Professional, dan Avira Premium Security Suite.
Kata Pak Dirk Knop, Avira Technical Editor, pengguna Avira nantinya dapat bergabung dengan komunitas Avira, dan mengirim sampel file asing berbahaya untuk diteliti lebih lanjut.
Versi terbaru dari Avira AntiVir ini memiliki fitur baru yang memungkinkan kemampuan Generic Repair. Dengan kemampuan tersebut, Avira tak hanya menghapus virus, trojan atau malware, namun juga memperbaiki kerusakan akibat malware tersebut.
Kata Pak Dirk juga proses instalasi hanya berjalan dengan tiga kali klik saja. Selain dua fitur tersebut, Avira juga memiliki fitur parental control yang sebaiknya dimanfaatkan para orangtua, untuk memantau aktivitas anak-anak mereka di internet.